Bug Hunt - Loss of Connection

Overwatch

Community Manager
Staff member
Greetings everyone! It's time to go on a hunt.. for a bug.. a big bug.. which we've been tracking for a while! This bug is the last bug, however it is the bug of bugs! With Tactics official release date only round the corner its important we iron out this last threat and so, we need you to help us find it! We know what the bug is, but we don't know why its there or what makes it occur. The bug is : Loss of connection

It occurs at some point in the game but for a reason unknown. What happens is during a raid, after you have finished your go, it passes onto the AI's turn. Once the AI has finished all its moves the game stops on your turn preventing you from moving any troops or making any progress in the game. The only ways to get around this bug are by refreshing the page or to wait out the loading time so it passes onto the AI.

We believe the occurrence of this bug is due to weak internet connection especially on wireless. If you experience this bug please take note of all other factors this includes:

what troops/vehicles are developed
last vehicle movement
anything suspicious with the AI movement
any ongoing animations/particle systems
timer countdown

Bug hunters, UNITE!

Charlie
 
Come to think of it, I've came into this bug once or twice and I had no idea what was going on. At one point I thought it was just me being silly but turns out its actually a bug lol
 

Overwatch

Community Manager
Staff member
Great job team! We're still keeping an eye out for this and we haven't made much progress. We are confident we can eliminate the threat though!
 

Ben

Private
i experienced something similar but just shrugged it off as a drop in my internet connection, now that i know its actually a bug i will keep an eye out for it.
 

Overwatch

Community Manager
Staff member
i experienced something similar but just shrugged it off as a drop in my internet connection, now that i know its actually a bug i will keep an eye out for it.
Hi Ben, welcome! Okay awesome it is something thats BUGGING us so any help is appreciated.

See what I did there?
 

null

Corporal
I have noticed that after hitting a base and bringing two or more wrecks home causes a glitch to happen that keeps me from unloading resources and moving my vehicles.
 

Overwatch

Community Manager
Staff member
I have noticed that after hitting a base and bringing two or more wrecks home causes a glitch to happen that keeps me from unloading resources and moving my vehicles.
Hi Null, welcome!

Do you have any more information on this 'bug'? Is it something you can reproduce? And what do you mean by unloading resources? Thanks though, we'll look into this :)
 

null

Corporal
hello, It can be reproduced. Resources are equal to harvesting or unloading, that is an option for the war drones if you salvage vehicles you toe home from a raid.
 

Overwatch

Community Manager
Staff member
hello, It can be reproduced. Resources are equal to harvesting or unloading, that is an option for the war drones if you salvage vehicles you toe home from a raid.
Okay thanks Null, This has been submitted to the devs now and they'll look into it :)
 

null

Corporal
I'm having a hard time getting my energy to re-spawn. I should have 15 but its stuck at 10. Help me please.
 

Overwatch

Community Manager
Staff member
Are the power plants destroyed and do you need to repair them after being raided? Take a screenshot of your base with the debugger open (f12 on google chrome) and go to the 'console' tab. this will tell us if anythings gone wrong :)
 

null

Corporal
Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check http://xhr.spec.whatwg.org/.
tactics.legendary-games.com/scripts/tactics/battle/view.js?bust=v52:527 world_process_recombine: 1903.000ms
tactics.legendary-games.com/scripts/tactics/battle/view.js?bust=v52:552 viewLoad: 5679.000ms
tactics.legendary-games.com/scripts/tactics/battle/view.js?bust=v52:494 setLoading: 5646.000ms
 

Overwatch

Community Manager
Staff member
Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check http://xhr.spec.whatwg.org/.
tactics.legendary-games.com/scripts/tactics/battle/view.js?bust=v52:527 world_process_recombine: 1903.000ms
tactics.legendary-games.com/scripts/tactics/battle/view.js?bust=v52:552 viewLoad: 5679.000ms
tactics.legendary-games.com/scripts/tactics/battle/view.js?bust=v52:494 setLoading: 5646.000ms
We'll have to look into this tomorrow, could be something :p
 

Overwatch

Community Manager
Staff member
Have you checked to see if your powerplants are repaired? maybe they were injured in battle
 
Top