Unable to equip a scavenged item

Discussion in 'Bugs / Suggestions / Support' started by Marius Dire, Jul 6, 2018.

  1. Marius Dire Private

    Message Count:
    4
    Trophy Points:
    1
    Hello,

    So I recently came across some gromil armour, one of my dregs picked it during a battle from one of the corpse loot markers. (Couldn’t believe my luck.)

    When I went to the camp screen to equip it the item was not there. I double checked this by going to the store and I can see in this case the item is there to sell.

    I thought it might have been that I could not equip this to a dreg, so I tested this by removing the gromil armour from my vampire and it seems that the dreg can equip that, so he should be able to equip the gromil armour he has found.

    I then left the vampire’s gromil armour on the dreg and tried to equip the found armour to the vampire but it was not visible for him m to equip either.

    I have tried recreating the bug with a club and a falchion I found in the same way but was unable to.

    My warband is an undead one called The Exiles. I don’t recall the map I found the armour on but I think it was the memorial gardens. (It was definitely one of the graveyard ones.) The warband I was fighting were called the gentleman of Cali (like out of Narcos.). I voluntarily routed once my way bands wounds were under 50% and the dreg who found the armour was still active and carrying it when this happened.

    I have tried to upload screenshots of the camp screen where I cannot equip the armour and the armour appearing in the store, but apparently they’re too big. Can send them via email if required.

    And as this is my first post here; Hi, really enjoying the game so far.
  2. Shangular Major

    Message Count:
    190
    Trophy Points:
    31
    Yup. I’ve run into this bug too in the past. One way I found to fix it is to buy a gromil Armour. Yes it costs gold but then you’ll have 2 gromils to equip for your warband.
    Marius Dire likes this.
  3. Marius Dire Private

    Message Count:
    4
    Trophy Points:
    1
    That is eventually what I did. It might be worth noting that the armour I bought from the store had the Sylvanian crest on it (you know the bat thingy on the red shield.). Where as the one I found did not, I’m not sure if it needs to be tagged as being for the undead (since my warband is undead) so I can equip it, and maybe the found armour isn’t tagged.

    TLDR: Took your advice it worked thanks.

Share This Page