Upgrade stock glitch

Discussion in 'Bugs and Suggestions' started by Zero_Harker, Jan 11, 2014.

  1. Zero_Harker Private

    Message Count:
    25
    Trophy Points:
    3
    Came back on after analysing these two upgrades (again) and for some reason I have a massive stack of them out of nowhere.
    [IMG]
  2. Gareth Corporal

    Message Count:
    84
    Trophy Points:
    8
    I had this glitch too just after creating an upgrade for a unit. Not too sure what the cause is but it happened while I had a single infantry unit selected and created an upgrade from within it, then applied the upgrade in there (instead of creating it on the stock selection menu).
  3. SteveGreen Private

    Message Count:
    29
    Trophy Points:
    3
    Yeah, I just also experienced this glitch while upgrading a unit while on the more detailed unit page. It gave me a stock of 32767, instead of 1, which is also the maximum value of a 16-bit signed integer.

    edit: it's also worth noting that despite analysing the upgrade, the game still thinks I lack the blueprint for it.
  4. Zero_Harker Private

    Message Count:
    25
    Trophy Points:
    3
    Yeah I've been having trouble with blueprints and stuff too, had similar things aswell where I've researched a blueprint then got a ton of them and still no blueprint X_X
  5. Gareth Corporal

    Message Count:
    84
    Trophy Points:
    8
    Saying that for me too, I wonder what happens if you analyze an upgrade twice?
  6. Zero_Harker Private

    Message Count:
    25
    Trophy Points:
    3
    Happened again this morning with a Scavenger upgrade, analysed for 15 energy then didn't have the blueprint but once again had 367etc stock
  7. Jemma Corporal

    Message Count:
    131
    Trophy Points:
    18
    Just to let you know that Gavin is aware of this and he's going to look into it. :)
  8. Gavin Rummery
    Administrator

    Message Count:
    68
    Trophy Points:
    11
    Whoa, this looks a bit of a major glitch!

    Can you guys explain exactly what steps you took that caused this to happen? We've been testing here and haven't been able to reproduce it yet. E.g. is it from the unit detail screen or warehouse? Are you researching from scratch or analysing an existing upgrade?
  9. Gavin Rummery
    Administrator

    Message Count:
    68
    Trophy Points:
    11
    OK, I think we found and fixed the problem and repaired your accounts. It happened when you built an upgrade on the unit equipping screen.

    Let us know if you see a recurrence of this problem!!
  10. Zero_Harker Private

    Message Count:
    25
    Trophy Points:
    3
    Yeh just checked and it's fixed now, excellent work
  11. Xenoblade Hero Private

    Message Count:
    8
    Trophy Points:
    3
    This happened to me on an earlier build of the game (before the update). I assumed it had been fixed then but it's good to hear that the glitch has been found and identified
    Zero_Harker likes this.

Share This Page